
Excel Power Pivot

Let’s break down the PowerPivot window and how to navigate it in Excel.

PowerPivot Window Overview
PowerPivot is an add-in for Excel that allows you to create data models, establish relationships, and perform complex 

calculations. Here’s how you can navigate the PowerPivot window:

Enabling PowerPivot:

Go to Data > Data tools > Click Data Model > Manage Data Model.

The PowerPivot tab will now appear in the Excel ribbon1.

Opening the PowerPivot Window:

Click on the PowerPivot tab in the ribbon.

Select Manage from the Data Model section. This opens the PowerPivot window.

Navigating the PowerPivot Window

Once you’re in the PowerPivot window, you’ll see several key areas:

Data View:

This is the default view where you can see your tables of data on different tabs, similar to worksheets in Excel.

You can add, edit, and delete data here.

Diagram View:

Click the Diagram View icon at the bottom right to see a graphical representation of the relationships between your tables.

This view helps you understand and manage the connections between different data sets.

Field List:

On the right side, you’ll find the Field List, which shows all the tables and fields available in your data model.

You can drag and drop fields to create calculations, measures, and KPIs (Key Performance Indicators).

Exploring the PowerPivot Tab in Excel

The PowerPivot tab in Excel provides several options:
Manage:

Opens the PowerPivot window where you can manage your data model.

Data Model:

Allows you to create and manage relationships between tables.

Measures:

Create calculated fields using DAX (Data Analysis Expressions).

KPIs:

Define and manage Key Performance Indicators to track performance metrics.

Linked Tables:

Create tables in Excel that are linked to your PowerPivot data model.

PowerPivot is a powerful tool for data analysis and modeling, making it easier 

to work with large data sets and perform complex calculations within Excel.

Unleash the Power of Your Data: A Look at Excel Power Pivot

Add Data to PowerPivot:
Go to the PowerPivot tab in the Excel ribbon.

Click on Manage to open the PowerPivot window.

In the PowerPivot window, click on Get External Data.

Select the data source you want to import from (e.g., SQL Server, 

Access, Excel, etc.) and follow the prompts to 

connect to your data source and import the data.
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Working with Tables and Columns
PowerPivot allows you to import data from various sources and organize it into tables. Here’s how you can work with 

tables and columns:

Import Data: You can import data from Excel files, databases, and other sources into PowerPivot.

Create Tables: Once imported, data is organized into tables. You can rename tables and columns for better clarity.

Add Calculated Columns: You can create new columns using formulas to perform calculations on existing data.

Filtering and Sorting Data:

Filtering and sorting help you manage and analyze your data more effectively:

Sorting: You can sort data in ascending or descending order based on any column. This helps in organizing data for 

better readability.

Filtering: Filters allow you to display only the data that meets certain criteria. You can use basic filters, advanced filters, 

or the FILTER function to refine your data.

Diagram View: In PowerPivot, you can use the Diagram View to visually create relationships between tables by dragging 

and dropping fields.

Manage Relationships: You can also manage relationships manually by specifying which columns in different tables 

should be linked.

Creating and Working with Calculations

PowerPivot uses Data Analysis Expressions (DAX) for creating calculations:

Calculated Columns: These are new columns added to tables using DAX formulas. They perform row-by-row calculations.

Measures: Measures are calculations used in data analysis, such as sums, averages, or more complex aggregations. 

They are dynamic and change based on the context of the data in PivotTables.

Unleash the Power of Your Data: A Look at Excel Power Pivot

Creating Relationships Between Tables
Creating relationships between tables is crucial for data analysis:

Open Diagram View: In the PowerPivot window, switch to Diagram 

View by clicking the Diagram View button. This will display your 

tables in a visual layout.

Create Relationships: Drag and drop fields between tables to 

create relationships. For example, if you have a CustomerID 

field in both the Orders and Customers tables, drag CustomerID 

from one table to the other to create a relationship.

Verify Relationships: Ensure that the relationships are correctly

 established by creating a PivotTable that includes fields from 

both tables. If the data looks correct, your relationships are set 

up properly.
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Use PowerQuery to connect to data sources for use in Power Pivot
Power Query is a powerful feature in Microsoft Excel that allows you to import, transform, and analyze data from various 

sources. Here’s a brief overview of what Power Query can do:

Import Data: You can use Power Query to import data from a wide range of sources, including databases, Excel files, 

text files, web pages, and more.

Transform Data: Once the data is imported, Power Query provides a range of tools to clean and transform the data. 

This includes removing columns, changing data types, filtering rows, and more.

Combine Data: Power Query can merge and append data from multiple sources, giving you a unified view of the 

information.

Automate Processes: After setting up a query, you can easily refresh it to pull in new or updated data with just a few clicks.

No Coding Required: The Power Query Editor records all your transformations step by step and converts them into 

M code for you, similar to how the Macro recorder works with VBA. You don’t need to write any code unless you want to.

Solve date problems in Excel with Power Query

The Magic of Power Query

Connecting to external data
Connecting to external data with Power Query in Microsoft 

Excel involves several steps. Here’s a simplified guide:

Open Excel and go to the Data tab.

In the Get & Transform Data group, click on Get Data.

Choose your external data source from the options. 

Power Query can connect to many data sources, 

including CSV, XML, JSON, PDF, SharePoint, SQL, and more.

Once you select the data source, the Navigator pane will 

open, allowing you to browse and preview the data.

Select the tables or queries you want to import.

After selecting the data, you can transform it by removing 

columns, changing data types, or merging tables to meet 

your needs.

Finally, load your query into Excel to create charts and reports.

Clean, merge, append, and group
Power Query is a powerful tool in Excel that allows you to perform various data manipulation tasks. Here’s a brief 

explanation of the terms you’ve asked about:

Clean: Cleaning data involves removing errors, inconsistencies, and unnecessary information from your dataset. 

This could include actions like removing duplicates, filling in missing values, correcting errors, or standardizing formats.

Merge: Merging is the process of combining two datasets into one by connecting rows based on a common key or 

column. It’s similar to a SQL join. You can perform different types of joins such as inner, outer, left, and right joins 

depending on the requirement.

Append: Appending is when you take two or more datasets with the same structure and stack them on top of each 

other to create a single, continuous dataset. This is useful when you have data split across multiple files or tables but 

need to analyze it as one.

Group: Grouping data in Power Query allows you to aggregate data based on a certain category. For example, you 

could sum up sales figures by region or count the number of transactions per product category. It’s a way to 

summarize data for easier analysis.

Clean data in Power Query
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Overview of Data Analysis Expressions (DAX) Language
DAX is a formula language used in PowerPivot, Power BI, and other Microsoft data tools. It allows you to create 

custom calculations and aggregations in your data models. DAX is similar to Excel formulas but is designed to work 

with relational data and perform more complex calculations.

Building Formulas for Calculated Columns and Measures

Calculated Columns: These are added to tables in your data model and are calculated row by row. For example, 

you might create a calculated column to combine first and last names into a full name.

Measures: These are calculations used in data analysis, often aggregating data. Measures are calculated on the fly 

and are typically used in reports and dashboards. For example, you might create a measure to calculate total sales.

Understanding the Use of Relationships and Lookups in Formulas

Relationships: In PowerPivot, you can create relationships between tables, similar to how you would in a database. 

This allows you to pull data from related tables into your calculations.

Lookups: DAX includes functions like RELATED and LOOKUPVALUE that allow you to fetch data from related tables. 

This is useful for combining data from different sources.

Understanding Aggregations in Formulas

Aggregations are used to summarize data. Common aggregation functions in DAX include SUM, AVERAGE, MIN, 

MAX, and COUNT. These functions help you to quickly calculate totals, averages, and other summary statistics.

Filtering Data in Formulas

DAX allows you to filter data within your formulas using functions like FILTER, ALL, and CALCULATE. These functions 

enable you to create more dynamic and context-specific calculations. For example, you might use CALCULATE to 

create a measure that only sums sales for a specific region.

Recalculating Formulas

Formulas in PowerPivot are recalculated automatically when the data changes. This ensures that your calculations 

are always up to date. However, you can also manually trigger recalculations if needed.

DAX Examples
1. Calculated Columns

A calculated column is added to an existing table in your data model. 

Here’s an example:

Creating a Full Name Column:

FullName: = [FirstName] & " " & [LastName]

This formula concatenates the first and last names into a single column.

2. Measures

Measures are calculations used in data analysis, often in PivotTables. 

They are dynamic and change based on the context of the data.

Total Sales:

TotalSales: = SUM(Sales[Amount])

This measure calculates the total sales amount.
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3. Time Intelligence

DAX includes functions to work with dates and times, allowing 

for complex time-based calculations.

Year-to-Date Sales:

YTD_Sales:: = TOTALYTD(SUM(Sales[Amount]), Sales[Date])

This measure calculates the year-to-date sales.

4. Conditional Values

You can create values based on conditions, similar to 

IF statements in Excel.

Sales Category:

SalesCategory: = IF(Sales[Amount] > 1000, "High", "Low")

This formula categorizes sales as “High” or “Low” based on the 

amount.

5. Ranking

DAX can also be used to rank data.

Rank Products by Sales:

ProductRank: = RANKX(ALL(Products), [TotalSales], , DESC)

This measure ranks products based on their total sales.
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Reasons to use Power Pivot:
Handling Large Data Sets: Power Pivot allows you to work with large volumes of data, making it possible to analyze millions of 
rows efficiently.

Data Integration: You can import data from various sources, such as databases, spreadsheets, and online services, and 
combine them into a single data model.

Relationships Between Tables: Power Pivot enables 

you to create relationships between different tables, eliminating the need for complex VLOOKUPs. This makes it easier to 
analyze data from multiple tables.

Advanced Calculations with DAX: Power Pivot uses 

the Data Analysis Expressions (DAX) formula language, 

which allows for more complex calculations and data 

analysis than standard Excel formulas.

High Performance: The internal data model and efficient 

processing capabilities of Power Pivot ensure high 

performance, even with large data sets.

Familiar Excel Interface: Since Power Pivot is integrated into 

Excel, you can leverage your existing Excel skills and work 

within a familiar environment.

Excel Power Pivot

Ask questions on our 

post course learning 

support forum 

Log in using your email 

and your post course 

email when you 

completed the feedback

Creating PivotTables from PowerPivot data model
Insert a PivotTable:

Go to the Insert tab in Excel.

Click on PivotTable.

In the Create PivotTable dialog box, select Use an external data 

source.

Click Choose Connection and select your PowerPivot data model.

Build Your PivotTable:

In the PivotTable Field List, drag fields to the Rows, Columns, and 

Values areas.

Customize your PivotTable by sorting, filtering, and formatting 

the data as needed.

Creating PivotCharts

Insert a PivotChart:

Go to the Insert tab.

Click on PivotChart.

In the Create PivotChart dialog box, select Use an external data 

source.

Click Choose Connection and select your PowerPivot data model.

Build Your PivotChart:

In the PivotChart Field List, drag fields to the Axis (Categories), Legend (Series), and Values areas.

Customize your PivotChart by choosing different chart types, formatting, and adding titles or labels.

Unleash the Power of Your Data: A Look at Excel Power Pivot
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